Back
Resolved

Network Redundancy Upgrade

Completed 13 May at 07:00am CEST.

ADFS Ayon Internet Access Servers Availability
Completed

Maintenance ended

Posted 13 May at 07:00am CEST.
Started

Upgrading the core network to add a second router.

Posted 12 May at 08:30pm CEST.